summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLev Lybin2015-08-08 19:43:42 +0700
committerLev Lybin2015-08-08 19:43:42 +0700
commita972c2472d1510056d091639508711feb3a2503e (patch)
tree8903073ebb4f4dda58813cd9c3a8b96f1a2529dc /PKGBUILD
downloadaur-a972c2472d1510056d091639508711feb3a2503e.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d167d97ea671
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Lev Lybin <lev.lybin@gmail.com>
+# Contributor: Lev Lybin <lev.lybin@gmail.com>
+
+_pkgname=python-wifi
+pkgname=python2-wifi
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="A Python module that provides read and write access to a wireless network card's capabilities using the Linux Wireless Extensions."
+arch=('any')
+url="https://pypi.python.org/pypi/python-wifi"
+license=('LGPL' 'GPL')
+depends=('python2')
+makedepends=('python2-distribute')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.bz2")
+md5sums=('f9d520a8c17b0dfffce95a8a7efba7dd')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ # fix unicode error
+ sed -i '/author = \"R/c\ author = \"Roman Joost\",' "${srcdir}/${_pkgname}-${pkgver}/setup.py"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+} \ No newline at end of file