summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorViliam Pucik2019-05-02 10:49:47 +0200
committerViliam Pucik2019-05-02 10:49:47 +0200
commitde6dcb5cecb829cd69450e0187e44c2cddccab63 (patch)
tree871be6ff29ef7f2b59b672736f3509b9fe3388c8 /PKGBUILD
downloadaur-de6dcb5cecb829cd69450e0187e44c2cddccab63.tar.gz
0.27 version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f595bdea34ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Based on yapf 0.27.0 PKGBUILD
+# Maintainer: Viliam Pucik <viliam dot pucik at pm dot me>
+
+name=yapf
+pkgname=python2-$name
+pkgver=0.27.0
+pkgrel=1
+pkgdesc="Python style guide checker"
+arch=('any')
+url="https://github.com/google/yapf"
+license=('Apache')
+depends=('python2-setuptools')
+checkdepends=('python2-nose')
+source=("$name-$pkgver.tar.gz::https://github.com/google/$name/archive/v$pkgver.tar.gz")
+sha512sums=('d161c232d485ce7a6173fc6d796ed9bd880736d365d61f27fd608b590dddfc3fa8fd60fa88d8ebee8e63db616761ede6f1dfa74579c8ec9df5d3c81b50dc2ade')
+
+build() {
+ cd $name-$pkgver
+ python2 setup.py build
+}
+
+check() {
+ cd $name-$pkgver
+ nosetests2 || warning "https://github.com/google/yapf/issues/586"
+}
+
+package() {
+ cd $name-$pkgver
+ python2 setup.py install -O1 --root="$pkgdir"
+ mv "$pkgdir"/usr/bin/yapf{,2}
+}