summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesse Jaara2018-03-07 00:21:19 +0200
committerJesse Jaara2018-03-07 00:21:19 +0200
commit0f500c8fa253c38cb49356c27adfc84e7c461ba5 (patch)
tree6f548c8c5daabf370e321df13d71651b8cdbcdaf /PKGBUILD
parentd78825a338fa3420425b8726a01f1fef9271df39 (diff)
downloadaur-0f500c8fa253c38cb49356c27adfc84e7c461ba5.tar.gz
Update to version 2018.03.03.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9e5e07b09f9..9954133ca628 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Eric BĂ©langer <eric@archlinux.org>
pkgname=python2-youtube-dl
-pkgver=2017.06.05
+pkgver=2018.03.03
pkgrel=1
pkgdesc="A small command-line program to download videos from YouTube.com and a few more sites"
arch=('any')
@@ -11,15 +11,18 @@ license=('custom')
depends=('python2')
makedepends=('python2-setuptools')
optdepends=('ffmpeg: for video post-processing'
- 'rtmpdump: for rtmp streams support')
+ 'rtmpdump: for rtmp streams support'
+ 'atomicparsley: for embedding thumbnails into m4a files'
+ 'python-crypto: for hlsnative downloader')
source=(http://youtube-dl.org/downloads/${pkgver}/youtube-dl-${pkgver}.tar.gz
http://youtube-dl.org/downloads/${pkgver}/youtube-dl-${pkgver}.tar.gz.sig)
-sha256sums=('b54ca848490285909d0830c04c19376c2d78da74d8de0056387b11ba34234e8c'
+sha256sums=('a8a061d6cd6ee311c079ea26d4edfadbf5fa817f8dc68c7e42e56896212f15f4'
'SKIP')
validpgpkeys=('7D33D762FD6C35130481347FDB4B54CBA4826A18' 'ED7F5BF46B3BBED81C87368E2C393E0F18A9236D')
package() {
cd youtube-dl
+
python2 setup.py install --root="${pkgdir}/" --optimize=1
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/python2-youtube-dl/LICENSE"