summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormatoro2017-03-20 21:22:03 -0500
committermatoro2017-03-20 21:22:03 -0500
commit825376e5fa6aefe2385a6546720efc876e1b0557 (patch)
tree94e390f973d3433e28b27f43dc5a891883c30b50 /PKGBUILD
downloadaur-825376e5fa6aefe2385a6546720efc876e1b0557.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1e5e69442b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: matoro <matoro@airmail.cc>
+# Contributor: Lari Tikkanen <lartza@wippies.com>
+
+pkgname=python2-youtube-dl-git
+_gitname="youtube-dl"
+pkgver=2017.03.20.r2.8a8cc339b
+pkgrel=1
+pkgdesc="A small command-line program to download videos from YouTube.com and a few more sites (git version)"
+arch=('any')
+url="https://github.com/rg3/youtube-dl"
+license=('custom')
+depends=('python2')
+makedepends=('git' 'python2-setuptools' 'pandoc')
+optdepends=('ffmpeg: for video post-processing'
+ 'rtmpdump: for rtmp streams support')
+provides=("python2-youtube-dl")
+conflicts=("python2-youtube-dl")
+source=('git+https://github.com/rg3/youtube-dl.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/$_gitname
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd $srcdir/$_gitname
+ make pypi-files
+}
+
+package() {
+ cd $srcdir/$_gitname
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ rm -r "${pkgdir}/usr/etc"
+ rm -r "${pkgdir}/usr/bin"
+ rm -r "${pkgdir}/usr/share/man"
+ rm -r "${pkgdir}/usr/share/doc"
+}