summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStuart Mumford2015-08-25 11:54:11 +0100
committerStuart Mumford2015-08-25 11:54:11 +0100
commitac3bb786523e527e3d652abbfbf45c59653073a0 (patch)
tree6a98ba389f41d78db06dae80169694d0d945e239 /PKGBUILD
downloadaur-ac3bb786523e527e3d652abbfbf45c59653073a0.tar.gz
First upload of python2-yt
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29a6663b2647
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Stuart Mumford <stuart@cadair.com>
+pkgname=python2-yt
+_module_name=yt
+pkgver=3.2
+pkgrel=1
+pkgdesc="Framework for plotting astronomical and geospatial data"
+arch=(any)
+url="http://yt-project.org"
+license=('BSD')
+depends=('python2-numpy' 'python2-matplotlib' 'cython2' 'python2-nose' 'python2-sympy' 'python2-h5py')
+optdepends=('ipython2' 'ipython2-notebook')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/y/${_module_name}/${_module_name}-${pkgver}.tar.gz")
+md5sums=('1bd2eaa05a06a85c53dee87626454df8')
+
+package() {
+ cd "$srcdir/${_module_name}-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 COPYING.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: