summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJerome Leclanche2015-06-09 23:34:14 +0200
committerJerome Leclanche2015-06-09 23:34:14 +0200
commit743471c75dc781b50964b9f2d8b044c99f9b7f79 (patch)
tree4322eda87bde8ebaa994ae4560a7ecde4931e6ea /PKGBUILD
downloadaur-python25.tar.gz
Initial import from old AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1fa9c09f878
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+
+_pkgname=Python
+pkgname=python25
+pkgver=2.5.6
+pkgrel=4
+pkgdesc="A high-level scripting language"
+arch=(i686 x86_64)
+license=("custom")
+url="https://www.python.org"
+depends=("db" "bzip2" "gdbm" "openssl" "zlib" "gcc-libs" "readline")
+optdependss=("sqlite")
+makedepends=("tk")
+source=(
+ "https://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.bz2"
+ "https://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.bz2.asc"
+)
+sha256sums=(
+ "57e04484de051decd4741fb4a4a3f543becc9a219af8b8063b5541e270f26dcc"
+ "SKIP"
+)
+validpgpkeys=(
+ # https://www.python.org/downloads/
+ "CBC547978A3964D14B9AB36A6AF053F07D9DC8D2"
+)
+options=("!makeflags")
+
+
+build() {
+ cd "$srcdir/Python-$pkgver"
+
+ export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:$srcdir/Python-$pkgver"
+ export CXX="g++"
+ ./configure \
+ --prefix=/usr \
+ --enable-shared \
+ --with-thread \
+ --enable-ipv6 \
+ --enable-unicode
+ make
+}
+
+package() {
+ cd "$srcdir/Python-$pkgver"
+ export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:$srcdir/Python-$pkgver"
+
+ make DESTDIR="$pkgdir" altinstall
+
+ # Rename all the scripts
+ pushd "$pkgdir/usr/bin"
+ mv idle idle2.5
+ mv pydoc pydoc2.5
+ mv smtpd.py smtpd2.5.py
+ popd
+
+ # License
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}