summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorskydrome2022-08-29 16:18:27 -0400
committerskydrome2022-08-29 16:18:27 -0400
commit764908e8892fe2210e9c9fb6b4f8ef8742a07270 (patch)
tree364341f741226405648c7775bd4d2afa3b496243 /PKGBUILD
parent7700fc573d6220984700a68fa4affe277ea0d3e6 (diff)
downloadaur-764908e8892fe2210e9c9fb6b4f8ef8742a07270.tar.gz
remove python2 package and install using a wheel
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de963e0f6649..080fe9884428 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,25 @@
# Contributor: Peter Simons <simons@cryp.to>
pkgbase=pyutil
-pkgname=('python2-pyutil' 'python-pyutil')
+pkgname=python-pyutil
pkgver=3.3.0
pkgrel=1
pkgdesc="general-purpose python library (used by tahoe-lafs)"
arch=('any')
url='https://pypi.python.org/pypi/pyutil'
license=('GPL2')
-makedepends=('python2-setuptools' 'python-setuptools')
+depends=('python')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
source=("https://files.pythonhosted.org/packages/source/p/pyutil/pyutil-${pkgver}.tar.gz")
sha256sums=('8c4d4bf668c559186389bb9bce99e4b1b871c09ba252a756ccaacd2b8f401848')
-package_python2-pyutil() {
- depends=('python2-simplejson' 'python2-zbase32')
- replaces=('pyutil')
- conflicts=('python-pyutil')
- cd "$srcdir/pyutil-$pkgver"
- python2 setup.py install --root="$pkgdir" --prefix='/usr' --optimize=1
- rm -r "$pkgdir/usr/pyutil"
+build() {
+ cd "pyutil-$pkgver"
+ python -m build --wheel --no-isolation
}
package_python-pyutil() {
- depends=('python-simplejson' 'python-zbase32')
- conflicts=('python2-pyutil')
- cd "$srcdir/pyutil-$pkgver"
- python setup.py install --root="$pkgdir" --prefix='/usr' --optimize=1
+ cd "pyutil-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
rm -r "$pkgdir/usr/pyutil"
}