summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-08-30 13:40:52 -0500
committerLuis Martinez2022-08-30 13:40:52 -0500
commitee7e9d0da4cdc72bf8c8981e190f56e55bd416ba (patch)
tree8401c3879c2913fbac074f4a3b8e643087d4a6cb /PKGBUILD
parent764908e8892fe2210e9c9fb6b4f8ef8742a07270 (diff)
downloadaur-ee7e9d0da4cdc72bf8c8981e190f56e55bd416ba.tar.gz
packaging cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 22 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 080fe9884428..22150446cc09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,36 @@
-# Maintainer: Nicolas Pouillard <nicolas.pouillard@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Nicolas Pouillard <nicolas.pouillard@gmail.com>
# Contributor: Peter Simons <simons@cryp.to>
pkgbase=pyutil
pkgname=python-pyutil
pkgver=3.3.0
-pkgrel=1
-pkgdesc="general-purpose python library (used by tahoe-lafs)"
+pkgrel=2
+pkgdesc="General-purpose python library (used by tahoe-lafs)"
arch=('any')
-url='https://pypi.python.org/pypi/pyutil'
+url='https://pypi.org/project/pyutil'
license=('GPL2')
depends=('python')
-makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/p/pyutil/pyutil-${pkgver}.tar.gz")
-sha256sums=('8c4d4bf668c559186389bb9bce99e4b1b871c09ba252a756ccaacd2b8f401848')
+optdepends=('python-simplejson: jsonutil support'
+ 'python-zbase32: randcookie support')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/p/pyutil/pyutil-$pkgver.tar.gz"
+ 'setup.py.patch')
+sha256sums=('8c4d4bf668c559186389bb9bce99e4b1b871c09ba252a756ccaacd2b8f401848'
+ 'c04d9474203ff677a0a23818d1d78eb7564f51f99dfac4ebf512170b5fdf7004')
+
+prepare() {
+ patch -p1 -d "pyutil-$pkgver" < setup.py.patch
+ rm -rf "$pkgbase-$pkgver/$pkgbase/test/"
+ find "$pkgbase-$pkgver" -name '*.pyc' -delete
+}
build() {
- cd "pyutil-$pkgver"
- python -m build --wheel --no-isolation
+ cd "$pkgbase-$pkgver"
+ python -m build --wheel --no-isolation
}
package_python-pyutil() {
- cd "pyutil-$pkgver"
- python -m installer --destdir="$pkgdir" dist/*.whl
- rm -r "$pkgdir/usr/pyutil"
+ cd "$pkgbase-$pkgver"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir" dist/*.whl
}