summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosip Ponjavic2017-03-11 20:03:09 +0100
committerJosip Ponjavic2017-03-11 20:03:09 +0100
commit21a01387e7a0d49c0c87425df25f9121fdaa9ab3 (patch)
treeeab4b5e56938f7cdd381f7f1aeb70b9c019015bd /PKGBUILD
parent4fb2aa1196a0924fdaf82e774a78c2cd123f5eab (diff)
downloadaur-21a01387e7a0d49c0c87425df25f9121fdaa9ab3.tar.gz
bump...
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ff0f2e54649a..f6dc2f8e5b9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Contributor:
pkgname=qactus-git
-pkgver=v0.7.0.r36.g8560b4c
-pkgrel=2
+pkgver=0.9.9.r311.g3fede1c
+pkgrel=1
pkgdesc="A Qt-based OBS notifier application."
arch=('i686' 'x86_64')
url="https://github.com/javierllorente/qactus"
license=('GPL2' 'GPL3')
-depends=('qtkeychain')
+depends=('hicolor-icon-theme' 'qtkeychain')
makedepends=('git')
conflicts=('qactus')
provides=('qactus')
@@ -17,7 +17,12 @@ md5sums=('SKIP')
pkgver() {
cd qactus
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ version=$(grep 'VERSION =' src/defines.pri | awk '{print $3}')
+ printf "%s.r%s.g%s" "$version" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ sed -i "s/lib64/lib/g" qactus/src/qobs/qobs.pro
}
build() {