diff options
author | Josip | 2016-04-28 13:44:18 +0200 |
---|---|---|
committer | Josip | 2016-04-28 13:44:18 +0200 |
commit | 4a34dab0274b4ba23d5498bd9579f25371fe148e (patch) | |
tree | 5680c1a4c3c0aa8ff2f5996ce4a2e1b20d0de113 /PKGBUILD | |
parent | 651aa3426eb56df18bfaf5e5e30e2840b0d4f3a7 (diff) | |
download | aur-4a34dab0274b4ba23d5498bd9579f25371fe148e.tar.gz |
Use hooks...
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 29 |
1 files changed, 10 insertions, 19 deletions
@@ -9,33 +9,24 @@ arch=('i686' 'x86_64') url="https://github.com/javierllorente/qactus" license=('GPL2' 'GPL3') depends=('qtkeychain-qt5') -makedepends=('git' 'harfbuzz') -conflicts=("${pkgname%-*}") -provides=("${pkgname%-*}") -install="${pkgname%-*}.install" +makedepends=('git') +conflicts=('qactus') +provides=('qactus') source=('git://github.com/javierllorente/qactus.git') md5sums=('SKIP') pkgver() { - cd "${pkgname%-*}" - - git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g' + cd qactus + git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g' } build() { - cd "${pkgname%-*}" - - if [[ -d build ]]; then - rm -rf build - fi - mkdir build && cd build - - qmake-qt5 PREFIX=/usr ../qactus.pro - make + cd qactus + qmake-qt5 PREFIX=/usr qactus.pro + make } package() { - cd "${pkgname%-*}"/build - - make INSTALL_ROOT="${pkgdir}" install + cd qactus + make INSTALL_ROOT="${pkgdir}" install } |