summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVladislav Suratov2021-01-07 00:21:44 +0300
committerVladislav Suratov2021-01-07 00:21:44 +0300
commitb57fe2f45423b5280da8e88d6e2e223523eaf72d (patch)
tree3f3f9973eaf99f761ab4a13adb288b15e4ff8cc7 /PKGBUILD
parentfc1a9e7697c9bc6e98f86774b619ae7d136476f1 (diff)
downloadaur-qbittorrent-dark-git.tar.gz
Update to 4.3.2.r236.g56ba037c6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8dc5bc1623e6..e0f37b4fd605 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: degreeme <suratovvlad@gmail.com>
pkgname=qbittorrent-dark-git
-pkgver=4.2.0.r20.gf9422a293
+pkgver=4.3.2.r236.g56ba037c6
pkgrel=1
pkgdesc="A dark version of bittorrent client powered by C++, Qt5 and the good libtorrent library (development version)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.qbittorrent.org/"
license=('custom' 'GPL')
depends=('libtorrent-rasterbar' 'qt5-base' 'libqdark-git')
@@ -16,6 +16,7 @@ source=("${pkgname%-*}::git+https://github.com/suratovvlad/qBittorrent.git"
"0001-Revert-Use-new-libtorrent-1.1.2-utility-function-to-.patch")
sha256sums=('SKIP'
'd020ac4ce37a871cb92e3f203cc5ccd6de24c1f0a369f7aea67a4be578c48b64')
+validpgpkeys=('D8F3DA77AAC6741053599C136E4A2D025B7CC9A2') # sledgehammer999 <sledgehammer999@qbittorrent.org>
pkgver() {
cd ${pkgname%-*}
@@ -37,6 +38,9 @@ prepare() {
build() {
cd ${pkgname%-*}
+ # tell qmake not to break makepkg's debug/!strip options
+ export QBT_ADD_CONFIG='nostrip'
+
./configure --prefix=/usr
make
}