summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorc0re1002023-06-22 16:34:39 +0800
committerc0re1002023-06-22 16:34:39 +0800
commit9bbe28e9d6ab4627c64c068e90cc10a5c80cb017 (patch)
tree8b7e7b4749e365e1334952e6f735b85c269d02f3 /PKGBUILD
parent9c05e37d3155587bc0b3af6d758542e6d9ce5407 (diff)
downloadaur-9bbe28e9d6ab4627c64c068e90cc10a5c80cb017.tar.gz
Fix Qt6 build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e3f6c4a7e512..a143489f467a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=qbittorrent-enhanced-git
pkgver=4.5.4.10.r0.g416904b36
-pkgrel=1
+pkgrel=2
pkgdesc="A bittorrent client powered by C++, Qt6 and the good libtorrent library (Enhanced Edition)"
arch=('arm' 'armv6h' 'armv7h' 'aarch64' 'i686' 'x86_64')
url="https://github.com/c0re100/qBittorrent-Enhanced-Edition"
license=('custom' 'GPL')
depends=('libtorrent-rasterbar' 'qt6-base' 'qt6-svg')
-makedepends=('boost' 'git' 'qt6-tools')
+makedepends=('cmake' 'boost' 'git' 'qt6-tools')
optdepends=('python: needed for torrent search tab')
conflicts=('qbittorrent')
provides=('qbittorrent')
@@ -27,16 +27,15 @@ pkgver() {
build() {
cd ${pkgname%-*}
- # tell qmake not to break makepkg's debug/!strip options
- export QBT_ADD_CONFIG='nostrip'
-
- ./configure --prefix=/usr CXXFLAGS="-std=c++17"
- make
+ cmake -B build -S . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DQT6=ON
+ cmake --build build
}
package() {
cd ${pkgname%-*}
- make INSTALL_ROOT="$pkgdir/" install
+ DESTDIR="$pkgdir" cmake --install build
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}