summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2015-05-28 20:37:38 +0200
committerCarsten Teibes2015-05-28 20:37:38 +0200
commit6e4c661fb2fb32965d14a218597a3d6001d38293 (patch)
tree242c076fe9e39c7b84167953f486aa8c3e38db8d /PKGBUILD
downloadaur-6e4c661fb2fb32965d14a218597a3d6001d38293.tar.gz
[add] qbittorrent-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84c7b4428116
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributors: Ner0, Sevenseven
+
+pkgname=qbittorrent-git
+pkgver=3.2.0.r5793.2c1d76c
+pkgrel=1
+pkgdesc="A bittorrent client written in C++ / Qt5 using the good libtorrent library (development version)"
+arch=('i686' 'x86_64')
+url="http://www.qbittorrent.org/"
+license=('custom' 'GPL')
+depends=('qt4' 'libtorrent-rasterbar' 'qjson')
+makedepends=('boost' 'git')
+optdepends=('python: needed for torrent search tab')
+conflicts=('qbittorrent' 'qbittorrent-qt5')
+provides=('qbittorrent' 'qbittorrent-qt4')
+install=qbittorrent.install
+source=(${pkgname%-*}::"git+https://github.com/qbittorrent/qBittorrent.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-*}
+
+ _tag=$(git tag -l | sort -r | head -n1 | tr -cd 0-9.)
+ _rev=$(git rev-list --count HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.%s" "$_tag" "$_rev" "$_hash"
+}
+
+build() {
+ cd ${pkgname%-*}
+
+ ./configure --prefix=/usr --with-qjson=system
+ make
+}
+
+package() {
+ cd ${pkgname%-*}
+
+ make INSTALL_ROOT="$pkgdir/" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}