summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEli Schwartz2017-03-12 01:11:45 -0500
committerEli Schwartz2017-03-12 01:11:45 -0500
commitb9b853ea1974b421e53893f08d825908ba3987c6 (patch)
tree1abf4ef6fe157745e179f21874cf994f0dfa0180 /PKGBUILD
parent3a965441cb56d5a654d6021f4a60b218c72b5696 (diff)
downloadaur-b9b853ea1974b421e53893f08d825908ba3987c6.tar.gz
upgpkg: qbittorrent-git 3.3.11.r1051.g9eb01fbe4-1
- upstream release - Less ugly way of using ugly hacks to obtain the version tag. - Fix prepare() since the problem commit can no longer be cleanly reverted; use a patchfile instead.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68cdd901175f..8d6ef026d7a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
pkgname=qbittorrent-git
-pkgver=3.3.10.r801.g33ada71e4
-pkgrel=2
+pkgver=3.3.11.r1051.g9eb01fbe4
+pkgrel=1
pkgdesc="A bittorrent client powered by C++, Qt5 and the good libtorrent library (development version)"
arch=('i686' 'x86_64')
url="http://www.qbittorrent.org/"
@@ -16,24 +16,26 @@ makedepends=('boost' 'git' 'qt5-tools')
optdepends=('python: needed for torrent search tab')
conflicts=('qbittorrent')
provides=('qbittorrent')
-source=("${pkgname%-*}::git+https://github.com/qbittorrent/qBittorrent.git")
-md5sums=('SKIP')
+source=("${pkgname%-*}::git+https://github.com/qbittorrent/qBittorrent.git"
+ "0001-Revert-Use-new-libtorrent-1.1.2-utility-function-to-.patch")
+sha256sums=('SKIP'
+ '33542b69eb46cf42273514143e6e76969dba03ad9bca58d09f9aa972a109efec')
pkgver() {
cd ${pkgname%-*}
- _tag=$(git tag -l | sort -rV | head -n1 | tr -cd 0-9.)
+ _tag=$(git tag -l --sort -v:refname | sed -n '1,1{s/release-//p}')
_rev=$(git rev-list --count release-${_tag}..HEAD)
_hash=$(git rev-parse --short HEAD)
printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash"
}
prepare() {
- cd ${pkgname%-*}/src
+ cd ${pkgname%-*}
# Remove this once libtorrent-rasterbar 1.1.2 is released and packaged
# See: https://github.com/qbittorrent/qBittorrent/issues/5888
- git revert --no-commit afe930cbeec5a1f8a397baf322eda9a8c4b58c80
+ patch -p1 < ../0001-Revert-Use-new-libtorrent-1.1.2-utility-function-to-.patch
}
build() {