summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Dewender2015-03-03 21:26:19 +0100
committerJohannes Dewender2015-03-03 21:26:19 +0100
commita156edeee867e7d4984c15b72dd8ea19cbec3e5b (patch)
treeed99c15b91894176b00e96a98c1c8fbc9e7b3df3 /PKGBUILD
parent40e1236c02413bcbb6f23e11d4df4f6e4a6ddb7d (diff)
downloadaur-a156edeee867e7d4984c15b72dd8ea19cbec3e5b.tar.gz
qbzr: fix package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 18 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6363520411e4..3cb9908226f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,35 @@
-# Maintainer : sebikul <sebikul@gmail.com>
+# Contributor: Johannes Dewender arch at JonnyJD dot net
+# Contributor: sebikul <sebikul@gmail.com>
#Contributed by Christian Rapp <saedelaere.tv@gmail.com>, based on:
#Contributed by Peter Dennis <listen.ppublic@gmail.com>, based on PKGBUILD by:
#Contributor: Ariel Kanterewicz <asdkant@gmail.com>
pkgname=qbzr
pkgver=0.23.0
-pkgrel=1
+pkgrel=2
pkgdesc="A GUI front end for Bazaar based on the Qt toolkit."
-arch=('i686' 'x86_64')
+arch=('any')
url="http://wiki.bazaar.canonical.com/QBzr"
-license=('GPL')
-depends=('python2-pyqt>=4' 'bzr' 'python2')
+license=('GPL2')
+depends=('python2-pyqt>=4.4' 'bzr>=2.6' 'python2>=2.4')
optdepends=('python2-pygments: for syntax highlighting'
'python2-pyenchant: for spell checking in commit dialogs')
source=("http://launchpad.net/${pkgname}/${pkgver%.*}/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz")
md5sums=('bd000c87e9cfeb78ea6629a4bee65ee5')
-build() {
-
+prepare() {
cd ${srcdir}/${pkgname}
+ # not sure if this is ever executed, but fixed anyways
+ sed -i -e '1s|python$|python2|' lib/uifactory.py
+}
- sed -i -e "s=/usr/bin/env python=/usr/bin/env python2=g" ./setup.py
-
- ./setup.py build || return 1
-
- ./setup.py install --prefix=$pkgdir/usr install
+build() {
+ cd ${srcdir}/${pkgname}
+ python2 setup.py build
+}
-}
+package() {
+ cd ${srcdir}/${pkgname}
+ python2 setup.py install --skip-build --prefix=$pkgdir/usr
+}