summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSamuel Mesa2018-08-22 14:56:16 -0500
committerSamuel Mesa2018-08-22 14:56:16 -0500
commit0954df15c478a7d71fae2e4113cd8bb2b4b9c8df (patch)
tree9e5e48d0905e8317af3e93a0a768a2401df504b8 /PKGBUILD
parentca33155fbc5f002aee0567f005f8db6b6f8d3288 (diff)
downloadaur-0954df15c478a7d71fae2e4113cd8bb2b4b9c8df.tar.gz
Update version 2.1.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 28 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05ba4099cc9c..8a18e82937f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,47 @@
-# Maintainer: Tajidin Abd <tajidinabd at archlinux dot us>
-# Contributor: Antonio Rojas
-# Contributor: Samuel Mesa
+# Maintainer: Samuel Fernando Mesa <samuel.mesa at linuxmail dot org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>s
pkgname=qca-qt4
+_pkgname=qca
pkgver=2.1.3
pkgrel=1
-pkgdesc="Qt Cryptographic Architecture. Qt4 Build (GIT Version)"
+pkgdesc="Qt Cryptographic Architecture. Qt4 Build"
arch=('i686' 'x86_64')
license=('LGPL')
-url="http://download.kde.org/stable/qca/${pkgver}/src/qca-${pkgver}.tar.xz"
-depends=('qt4' )
+url=http://delta.affinix.com/qca/
+depends=(qt4 nss)
+optdepends=('pkcs11-helper: PKCS-11 plugin' 'botan: botan plugin')
+conflicts=(qca qca-gnupg qca-ossl)
+provides=(qca qca-gnupg qca-ossl)
+replaces=(qca qca-gnupg qca-ossl)
makedepends=('cmake' 'doxygen' 'git' 'botan' 'pkcs11-helper' 'libsasl' 'libgcrypt')
-optdepends=('botan: Botan plugin'
- 'pkcs11-helper: PKCS11 plugin'
- 'nss: nss plugin'
- 'libsasl: SASL plugin'
- 'libgcrypt: gcrypt plugin')
-conflicts=('qca-qt4')
-provides=('qca-qt4')
-source=("git://anongit.kde.org/qca.git")
-md5sums=('SKIP')
+source=("http://download.kde.org/stable/$_pkgname/$pkgver/src/$_pkgname-$pkgver.tar.xz" qca-openssl-1.1.patch qca-botan2.patch::"https://cgit.kde.org/qca.git/patch/?id=47163784")
+ sha256sums=('003fd86a32421057a03b18a8168db52e2940978f9db5ebbb6a08882f8ab1e353'
+ 'b1505bc313fd2f4e350cd4c94af69256c901afa419ae6700b208cb6e40e6926d'
+ '2b2c3103e47166eee46604288ba343b9ed1ccb957c54650e8eea770faab515e9')
prepare() {
mkdir -p build
- sed 's|_BSD_SOURCE|_DEFAULT_SOURCE|g' -i qca/CMakeLists.txt
+ cd $_pkgname-$pkgver
+ patch -p1 -i ../qca-openssl-1.1.patch # Fix build with OpenSSL 1.1 https://bugs.kde.org/show_bug.cgi?id=379810
+ patch -p1 -i ../qca-botan2.patch # Fix build with botan 2
}
build() {
cd build
- cmake ../qca \
- -DQT4_BUILD=ON \
+
+ cmake ../$_pkgname-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DQCA_INSTALL_IN_QT_PREFIX=ON \
- -DQCA_PLUGINS_INSTALL_DIR=/usr/lib/qt4/plugins \
- -DQCA_SUFFIX=qt4 \
- -DBUILD_TESTS=OFF
+ -DBUILD_TESTS=OFF \
+ -DQCA_LIBRARY_INSTALL_DIR=/usr/lib \
+ -DQCA_FEATURE_INSTALL_DIR=/usr/share/qt4/mkspecs/features/ \
+ -DQT4_BUILD=ON
+
make
}
package() {
- make -C build DESTDIR="${pkgdir}" install
-}
+ cd build
+ make DESTDIR="$pkgdir" install
+} \ No newline at end of file