summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVlad Pirlog2023-07-05 00:14:52 +0300
committerVlad Pirlog2023-07-05 00:14:52 +0300
commitfa040d6dc3f736ff79dde88ee7c6c092b98eb813 (patch)
treea75bb23c4ccc87e8394a594bdfce13772e480aea /PKGBUILD
parentc13dcbbe5aaa4286c2efeef4bbcd7d6fc25c7b62 (diff)
downloadaur-fa040d6dc3f736ff79dde88ee7c6c092b98eb813.tar.gz
Update to 0.6.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 19 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c8ea0d3c1d4..82d5445acccf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,34 @@
-# Maintainer: Rob Knegjens <rknegjens@gmail.com>
+# Maintainer: Vlad Pirlog <(firstname) at (lastname) dot net>
+# Contributor: Rob Knegjens <rknegjens@gmail.com>
+
pkgname=qcl
-pkgver=0.6.4
+pkgver='0.6.7'
pkgrel=1
pkgdesc='Quantum Computation Language'
arch=('i686' 'x86_64')
-url="http://tph.tuwien.ac.at/~oemer/qcl.html"
+url='http://tph.tuwien.ac.at/~oemer/qcl.html'
license=('GPL2')
-depends=('flex' 'bison' 'readline' 'ncurses' 'plotutils')
-source=("http://tph.tuwien.ac.at/~oemer/tgz/qcl-0.6.4.tgz" "makefile.patch")
-md5sums=('a440b8b4441ba31f7d66ca76b4894a38'
- '632c461469fd01012d4bc1cb7c3924b6')
+changelog='CHANGELOG.txt'
+makedepends=('flex' 'bison')
+depends=('readline' 'plotutils')
+source=("http://tph.tuwien.ac.at/~oemer/tgz/$pkgname-$pkgver.tgz"
+ 'makefile.patch'
+ 'CHANGELOG.txt')
+b2sums=('b4d345f06a3988652ffed71ce0133247ef07a8149a4b7c4719424b020274f095432b82d3edea85a0acbd0f185f9c3211614714dea09f5cc2e3df59ae81dd8b0d'
+ 'eaf473703c7d985aa5d8b4c47c563a4067f2f895a1e79414b3591c98e988d79617ee49eaee2ae1bd701ecc40a8a7d9d0e1995b9fb2e889433b028f6a87ba9b60'
+ '6e2e7733725a80c58d5c3b39ac3e11d7bc3e4e6a1df1b02e1a32cf912f04218eda918f0fb20cf99ad46cb42593abff683392cebaa8d7e2a12a12843928a09d54')
prepare() {
- cd "$srcdir/qcl-$pkgver"
+ cd "$pkgname-$pkgver"
patch -Np1 -i "$srcdir/makefile.patch"
}
build() {
- cd "$srcdir/qcl-$pkgver"
- make
+ cd "$pkgname-$pkgver"
+ make
}
package() {
- cd "$srcdir/qcl-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
}