summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcodestation2015-07-02 20:49:09 -0430
committercodestation2015-07-02 20:49:09 -0430
commitac01b9e91dfcf7c2f3ecf2b37fa37399bbfd578a (patch)
treedfa47a2d05e64b582ec7b0accbf79a2475985517 /PKGBUILD
downloadaur-ac01b9e91dfcf7c2f3ecf2b37fa37399bbfd578a.tar.gz
Updated to 0.3.9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3da8a0de9d71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: codestation <codestation404@gmail.com>
+
+pkgname=qcma-appindicator
+_pkgname=qcma
+pkgver=0.3.9
+pkgrel=1
+pkgdesc="Content Manager Assistant for the PS Vita (AppIndicator)"
+arch=("i686" "x86_64")
+url="https://github.com/codestation/qcma"
+license=('GPL')
+depends=('qcma>=0.3.9' 'libappindicator-gtk2')
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/codestation/${_pkgname}/archive/v${pkgver}.tar.gz")
+install=qcma-appindicator.install
+sha256sums=('46cdc03c9b1ad1ce7905dc194166291a917aee0deb38099f998914076e88c30d')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ # temporal patch to install icons in the correct path
+ sed -i '/INCLUDEPATH/a DATADIR = $$PREFIX/share' qcma_appindicator.pro
+
+ qmake-qt5 qcma_appindicator.pro PREFIX="/usr"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make INSTALL_ROOT="${pkgdir}" install
+}