summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkevku2018-06-01 17:43:36 +0300
committerkevku2018-06-01 17:43:36 +0300
commit7e344e61e6fcd601bdce3464e4e965f759ed1176 (patch)
treea0a38a8ff0024e2035a066a8e03aa5613462ad34 /PKGBUILD
parent5a41fd90fb68b7740008df14ebd1897ec6ab9e85 (diff)
downloadaur-7e344e61e6fcd601bdce3464e4e965f759ed1176.tar.gz
fix build qt5.11
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 129600d95e3e..e46288071e19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,22 @@
# Maintainer: kevku <kevku@gmx.com>
pkgname=qdigidoc
pkgver=3.13.6.1525
-pkgrel=1
+pkgrel=2
pkgdesc="Qt based UI application for verifying and signing digital signatures"
arch=('x86_64' 'i686')
url="http://www.id.ee/"
license=('LGPL2.1')
depends=('libdigidocpp>=3.13.5' 'opensc' 'qt5-base>=5.10.0' 'shared-mime-info' 'ccid' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools' 'qt5-translations')
-source=("https://installer.id.ee/media/ubuntu/pool/main/q/$pkgname/${pkgname}_$pkgver.orig.tar.xz")
-sha256sums=('75e86c2626647005d5d5bff94631eea7380802f5d9a78965eec126909558b2a2')
+source=("https://installer.id.ee/media/ubuntu/pool/main/q/$pkgname/${pkgname}_$pkgver.orig.tar.xz"
+ "qdigidoc-3.13.6.1525-qt5.11.patch")
+sha256sums=('75e86c2626647005d5d5bff94631eea7380802f5d9a78965eec126909558b2a2'
+ 'b0dacc044ff0a49053eb395b2301d423e72112bb7a053c6b270c6ab3c1a232b0')
prepare() {
[[ -d "$pkgname-build" ]] && rm -r "$pkgname-build"
mkdir "$pkgname-build"
+ patch -p1 -i "$srcdir/qdigidoc-3.13.6.1525-qt5.11.patch"
}
build() {