summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDoug Newgard2016-07-14 09:31:19 -0500
committerDoug Newgard2016-07-14 09:31:19 -0500
commit8fdc448cb9988c07c2ac146305000ce302f1434f (patch)
tree5a59793d69687b1dd6d2e0b415c6afb33eac1a11 /PKGBUILD
parentda6a840b2081e99f0021a8ecc9fb4a5563b9874b (diff)
downloadaur-8fdc448cb9988c07c2ac146305000ce302f1434f.tar.gz
Patch to fix single process builds
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bbdb452e47b7..46fc70b39ec4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,12 +32,17 @@ optdepends=('gpsbabel: GPS Tool plugin'
'python2-psycopg2: Processing plugin'
'python2-pyspatialite: Processing plugin'
'python2-yaml: Processing plugin')
-source=("http://qgis.org/downloads/$pkgname-$pkgver.tar.bz2")
-md5sums=('33547fe3a0a0a87de209702a9bb60fcc')
+source=("https://qgis.org/downloads/$pkgname-$pkgver.tar.bz2"
+ 'https://github.com/qgis/QGIS/commit/1cff3b57f023b90513f00e44a03b2f1340ac8ff1.patch')
+md5sums=('33547fe3a0a0a87de209702a9bb60fcc'
+ 'cef83c9ae72b4288f73e6133ec78716b')
prepare() {
cd $pkgname-$pkgver
+ # Fix building with a single process
+ patch -p1 -i ../1cff3b57f023b90513f00e44a03b2f1340ac8ff1.patch
+
# Fix references to "python"
sed -i 's/\(env \|\/usr\/bin\/\)python$/&2/' $(find . -iname "*.py")