summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDoug Newgard2015-11-09 12:57:11 -0600
committerDoug Newgard2015-11-09 12:57:11 -0600
commite35e58270b798b1172b81ce0b1c535b44d29206a (patch)
tree1ceb2949a4b12b411542e9cdeaf1ccb01c0f6c5d /PKGBUILD
parente45f32da011a0929aec911424bdf8adda6c69cf6 (diff)
downloadaur-e35e58270b798b1172b81ce0b1c535b44d29206a.tar.gz
Better build dir handling
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d17031edf75..bcb29c284a01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -63,16 +63,12 @@ prepare() {
# Fixing by hand shebang for .py files.
find . -iname '*.py' | xargs sed -ie 's:^#!/usr/bin/env python$:#!/usr/bin/env python2:'
find . -iname '*.py' | xargs sed -ie 's:^#!/usr/bin/python$:#!/usr/bin/env python2:'
+
+ [[ -d build ]] || mkdir build
}
build() {
- cd $pkgname-$pkgver
-
- if [ -d build ]; then
- rm -rf build
- fi
- mkdir build
- cd build
+ cd $pkgname-$pkgver/build
cmake -G "Unix Makefiles" ../ \
-Wno-dev \