summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJuraj Fiala2016-06-30 19:46:29 +0200
committerJuraj Fiala2016-06-30 19:46:29 +0200
commit01e5adcb4d0c1097499d9dc900fccc87f7a3695b (patch)
tree3a0333121424b3c64f00313a070ccc02f61be38e /PKGBUILD
downloadaur-01e5adcb4d0c1097499d9dc900fccc87f7a3695b.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..793f7190a47a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Juraj Fiala <doctorjellyface at riseup dot net>
+# Contributor: spider-mario <spidermario@free.fr>
+
+pkgname=qgnomeplatform
+_srcname=QGnomePlatform
+_commit=c603662
+_revision=16
+pkgver=0.1.r$_revision.g$_commit
+pkgrel=1
+pkgdesc='QPlatformTheme for a better Qt application inclusion in GNOME.'
+arch=('i686' 'x86_64')
+url='https://github.com/MartinBriza/QGnomePlatform'
+license=('LGPL2.1')
+depends=('qt5-base')
+makedepends=('git')
+provides=('qgnomeplatform')
+conflicts=('qgnomeplatform')
+source=("git+https://github.com/MartinBriza/$_srcname.git#commit=$_commit")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_srcname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $_srcname
+ qmake-qt5
+ make
+}
+
+check() {
+ cd $_srcname
+ make -k check
+}
+
+package() {
+ cd $_srcname
+ make INSTALL_ROOT="$pkgdir/" install
+}