summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2019-09-03 00:08:07 +0200
committerFabioLolix2019-09-03 00:08:07 +0200
commitf32f43dc1259a2a16db0989696a5dcfb07815c62 (patch)
treef3b57faab7bdc6b7669cd509e98d19c43ae9223c /PKGBUILD
parente619f792798d692b47082636e4316e0c74d9646a (diff)
downloadaur-f32f43dc1259a2a16db0989696a5dcfb07815c62.tar.gz
v0.8.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c9ea1e33786..9c9ad0fc559a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
pkgname=qimgv
-pkgver=0.7.3
+pkgver=0.8.2
pkgrel=1
pkgdesc="Qt5 image viewer with experimental webm playback"
arch=(x86_64 i686 armv6h armv7h aarch64)
url="https://github.com/easymodo/qimgv"
license=(GPL3)
-depends=(qt5-base qt5-imageformats qt5-svg mpv)
+depends=(qt5-base qt5-imageformats qt5-svg mpv exiv2)
makedepends=(cmake qt5-tools)
+optdepednds=('qt5-apng-plugin: animated png support'
+ 'qtraw: raw images support')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/easymodo/qimgv/archive/v${pkgver}.tar.gz")
-sha256sums=('f5c9e4dfdc0e9842c6cec5d2d546e6f77b2c33312f5cb416eaf50a29a0dc65a1')
+sha256sums=('a0edf03f71ea94d1bcd441cd21b8bb1eef07db27e2e8abf469449479c32479f8')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -22,7 +24,8 @@ build() {
cmake .. \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DVIDEO_SUPPORT=ON
+ -DCMAKE_INSTALL_LIBDIR=lib
+
make
}