summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Eigensatz2016-08-13 22:09:16 +0200
committerPatrick Eigensatz2016-08-13 22:13:02 +0200
commitadf854250741caecf204f520c800af7d9d8cce5d (patch)
tree9a33013277b6058949664f4d2bd65751770bbe99 /PKGBUILD
parentceed6fe594c50246c84f580585983afc659af783 (diff)
downloadaur-adf854250741caecf204f520c800af7d9d8cce5d.tar.gz
Some improvements to PKGBUILD
- Example text removed - Quoted $pkgdir to avoid errors if $pkgdir contains spaces - Removed the `-j9` flag for make - Use install instead of cp - Substitute the url in the sources array - Use $pkgname and $pkgver instead of "qjournalctl" and "0.2" to simplify future updates.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2d7c3e2feda8..1668da57a13d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,3 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
# Maintainer: Patrick Eigensatz <patrick.eigensatz@gmail.com>
pkgname=qjournalctl
@@ -14,17 +9,17 @@ url="https://github.com/pentix/qjournalctl/"
license=('GPL')
depends=('qt5-base')
makedepends=('gcc-libs-multilib')
-source=('https://github.com/pentix/qjournalctl/archive/v0.2.tar.gz')
+source=("$url/archive/v$pkgver.tar.gz")
md5sums=('debd87fb60d50c4bd01bec99cff80a40')
sha256sums=('ba29cbde9df05538fc4c81f649e40d3754a3d852ab6c064b78898d0f5cafaa7a')
build() {
- cd qjournalctl-0.2
+ cd "$pkgname-$pkgver"
sh autogen.sh
- make -j9
+ make
}
package() {
- mkdir -p $pkgdir/usr/bin/
- cp qjournalctl-0.2/qjournalctl $pkgdir/usr/bin/
+ mkdir -p "$pkgdir/usr/bin/"
+ install -m755 "$pkgname-$pkgver/$pkgname" "$pkgdir/usr/bin/"
}