summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Eigensatz2016-08-13 18:55:06 +0200
committerPatrick Eigensatz2016-08-13 18:56:54 +0200
commitfad41ec4bb8acbbce402be2df8bae33ea1eed9d8 (patch)
treebb370ec778f4ecb191e8ef04cb2afc6e79fbb134 /PKGBUILD
downloadaur-fad41ec4bb8acbbce402be2df8bae33ea1eed9d8.tar.gz
Initial commit and submission to the AUR
(Submit qjournalctl v0.2 to the AUR)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab3fc0cff138
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Patrick Eigensatz <patrick.eigensatz@gmail.com>
+pkgname=qjournalctl
+pkgver=0.2
+pkgrel=1
+epoch=
+pkgdesc="Qt-based graphical user interface for systemd's journalctl command"
+arch=('i686' 'x86_64')
+url="https://github.com/pentix/qjournalctl/"
+license=('GPL')
+groups=()
+depends=('qt5-base')
+makedepends=('gcc-libs-multilib')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+source=('https://github.com/pentix/qjournalctl/archive/v0.2.tar.gz')
+noextract=()
+md5sums=('debd87fb60d50c4bd01bec99cff80a40')
+sha256sums=('ba29cbde9df05538fc4c81f649e40d3754a3d852ab6c064b78898d0f5cafaa7a')
+validpgpkeys=()
+
+#prepare() {
+#}
+
+build() {
+ cd qjournalctl-0.2
+ ./autogen.sh
+ make -j9
+}
+
+#check() {
+#}
+
+package() {
+ mkdir -p $pkgdir/usr/bin/
+ cp qjournalctl-0.2/qjournalctl $pkgdir/usr/bin/
+}