summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukas Sabota2015-12-30 22:03:11 -0500
committerLukas Sabota2015-12-30 22:03:11 -0500
commit42c5771504bd9a6846d6dee7f2f2487ba131cca1 (patch)
treedcad7271659cf5543c7d0bc66ea4bff7a41c2019 /PKGBUILD
parent9fa1aaf0eb3a39c422c8fdf97da793c25f054c7f (diff)
downloadaur-qjoypad-panzi-git.tar.gz
add prepare function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 444267067ab0..6c2fef9003a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ conflicts=('qjoypad')
_gitroot=https://github.com/panzi/qjoypad.git
_gitname=qjoypad
-build() {
+prepare() {
cd "$srcdir"
msg "Connecting to GIT server...."
@@ -26,7 +26,13 @@ build() {
git clone "$_gitroot"
fi
+ pkgver=pkgver
+
msg "GIT checkout done or server timeout"
+}
+
+build() {
+ cd "$srcdir"
msg "Starting build..."
rm -rf "$srcdir/$_gitname-build"