summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJerome Lebleu2015-06-26 19:47:29 +0200
committerJerome Lebleu2015-06-26 19:47:47 +0200
commit975b94406fa46ab784f3ed9c873126ba9934d582 (patch)
treee7af4b1492e1cdc5dd6cad7f1e2882eee743648a /PKGBUILD
downloadaur-975b94406fa46ab784f3ed9c873126ba9934d582.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3feffef44660
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jerome Lebleu <jerome dot lebleu at mailoo dot org>
+
+pkgname=qlcplus
+pkgver=4.8.5
+pkgrel=1
+pkgdesc="Q Light Controller Plus - The open DMX lighting desk software for controlling professional lighting fixtures."
+arch=('i686' 'x86_64')
+url="http://qlcplus.org/"
+license=('APACHE')
+depends=('qt4' 'liblo' 'libftdi-compat' 'libsndfile' 'libmad' 'shared-mime-info' 'fftw')
+# ola need to be installed at build time for the plugin to be compiled
+optdepends=('ola: Open Lighting Architecture plugin')
+conflicts=('qlc' 'qlc-svn')
+install=${pkgname}.install
+source=("https://github.com/mcallegari/qlcplus/archive/QLC+_${pkgver}.tar.gz")
+md5sums=('8d72444b979a2d807aa9c9e793eefafa')
+
+build() {
+ cd "${srcdir}/qlcplus-QLC-_${pkgver}"
+ qmake-qt4
+ make
+}
+
+package() {
+ cd "${srcdir}/qlcplus-QLC-_${pkgver}"
+ make INSTALL_ROOT="${pkgdir}/" install
+}