summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMegumi_fox2021-07-19 22:08:31 +0800
committerMegumi_fox2021-07-19 22:08:31 +0800
commit9711534cbba2e70b57662e23545650f109ad72cd (patch)
treeb518b0d42d1e4aed83a2738c4ba3dfd538485a19 /PKGBUILD
parentbc5b1429a347d56dbe882562b9228e05c92eb586 (diff)
downloadaur-9711534cbba2e70b57662e23545650f109ad72cd.tar.gz
upgpkg 4.0.1.r0.gcd30fe8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d9a6e8aee884..47fbe724ec3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Megumi_fox <i@megumifox.com>
pkgname=qliveplayer-git
-pkgver=3.22.1.r0.ge0d6117
+pkgver=4.0.1.r0.gcd30fe8
pkgrel=1
pkgdesc='Cute and useful Live Stream Player with danmaku support.'
arch=('x86_64')
@@ -15,31 +15,36 @@ depends=('mpv'
'qt5-base'
'qt5-quickcontrols2'
'qt5-graphicaleffects'
- 'qt5-quickcontrols'
- 'python')
+ 'qt5-quickcontrols')
makedepends=('cmake'
'git'
+ 'rust'
'ninja'
'extra-cmake-modules' )
-optdepends=('python-protobuf: for YouTube LiveChat support'
- 'streamlink: for foreign streaming service support')
source=(
"QLivePlayer::git+https://github.com/IsoaSFlus/QLivePlayer.git"
+ "QLivePlayer-Lib::git+https://github.com/IsoaSFlus/QLivePlayer-Lib.git#branch=dev"
)
-pkgver() {
+pkgver(){
cd QLivePlayer
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd QLivePlayer
+ git submodule init
+ git config submodule.src/QLivePlayer-Lib.url "$srcdir/QLivePlayer-Lib"
+ git submodule update
+}
-sha256sums=('SKIP')
+sha256sums=('SKIP' 'SKIP')
build() {
cd $srcdir/QLivePlayer
mkdir -p build
cd build
- cmake -GNinja -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_LIBDIR=lib ..
+ cmake -GNinja -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
ninja
}