summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAkaash Suresh2020-01-14 15:03:24 -0600
committerAkaash Suresh2020-01-14 15:03:24 -0600
commite05cb8718fa3aad688e60f2f9b0549491128cf38 (patch)
tree2be59e0f61bb37a77df51ec2c102543e5a58db4b /PKGBUILD
downloadaur-e05cb8718fa3aad688e60f2f9b0549491128cf38.tar.gz
sync to git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0873d82d4709
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Akaash Suresh <https://github.com/Curry>
+pkgname=qmk-git
+pkgver=0.0.26
+pkgrel=3
+pkgdesc="CLI tool for customizing supported mechanical keyboards."
+arch=('any')
+url="https://github.com/qmk/qmk_cli"
+license=('MIT')
+_branch=qmk_cli
+depends=(
+ 'arm-none-eabi-binutils'
+ 'arm-none-eabi-gcc'
+ 'arm-none-eabi-newlib'
+ 'avrdude'
+ 'avr-binutils'
+ 'avr-libc'
+ 'python-appdirs'
+ 'python-argcomplete'
+ 'python-colorama'
+ 'avr-gcc'
+ 'clang'
+ 'dfu-programmer'
+ 'dfu-util'
+ 'diffutils'
+ 'gcc'
+ 'git'
+ 'libusb-compat'
+ 'unzip'
+ 'wget'
+ 'zip'
+ )
+makedepends=('python-setuptools' 'python' 'python-pip')
+source=('git+https://github.com/qmk/qmk_cli.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_branch"
+ echo $(git describe --tags)
+
+}
+
+build() {
+ pip install --no-deps --target="deps" yapf hjson
+ cd "$_branch"
+ python setup.py build
+}
+
+package() {
+ sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
+ cd "$_branch"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cp -r $srcdir/deps/* $pkgdir/"$sitepackages"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}