summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRicardo Gonçalves2017-06-13 14:42:46 +0100
committerRicardo Gonçalves2017-06-13 14:42:46 +0100
commit5ea26b36dd9d215093bd2bb5f52cdaafd67ff3c7 (patch)
treebee68251e6fad12a9545ed9e777fcd682689026a /PKGBUILD
parent0a852d609f8309c0f778b4a8af379dde9fb19161 (diff)
downloadaur-5ea26b36dd9d215093bd2bb5f52cdaafd67ff3c7.tar.gz
Fix broken PythonQt library installation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5375f6f1a214..a07d8fc47ddd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,16 @@ md5sums=('3fffbdf110c847942f7ce05fe373e57f')
build() {
cd "${pkgname}-${pkgver}"/
- qmake
+ # Fix missing libPythonQt.so
+ if [ ! -e "/usr/lib/libPythonQt.so" ]; then
+ libpython=$(find /usr/lib/ -type f -iname libpythonqt* ! -iname libPythonQt_QtAll*)
+ ln -svf "${libpython}" libPythonQt.so
+
+ qmake QMAKE_LIBDIR_FLAGS="-L $PWD"
+ else
+ qmake
+ fi
+
make -j4
}