summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzaps1662015-07-08 11:41:30 +0200
committerzaps1662015-07-08 11:41:30 +0200
commit88e758d4b387a0655443dc80fe9d36ac4e1a08ab (patch)
treef8d5fa497b38fef561dff8db3d73483bf23af2e6 /PKGBUILD
downloadaur-88e758d4b387a0655443dc80fe9d36ac4e1a08ab.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ffa810949eab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: zaps166 <spaz16@wp.pl>
+
+pkgname=qmplay2
+pkgver=15.06.26
+pkgrel=1
+pkgdesc='QMPlay2 is a video and audio player which can play most formats and codecs'
+arch=('i686' 'x86_64' 'armv7' 'armv6' 'armv5')
+url='http://qt-apps.org/content/show.php/QMPlay2?content=153339'
+license=('LGPL')
+depends=('qt4' 'ffmpeg' 'libass' 'libgl' 'libva' 'libxv' 'alsa-lib' 'libcdio' 'taglib' 'libcddb')
+optdepends=('pulseaudio' 'youtube-dl')
+makedepends=('make' 'gcc')
+source="http://downloads.sourceforge.net/project/zaps166/QMPlay2/QMPlay2-src-${pkgver}.tar.bz2"
+sha256sums=(fa35769d1742cee415ee1b4fec7f90c2f5b00b4f55b8774c98134d4925a6a728)
+
+build()
+{
+ cd $srcdir/QMPlay2-src
+ NOTERM=1 SYSTEM_BUILD=1 ./compile_unix 0
+}
+
+package()
+{
+ mv $srcdir/QMPlay2-src/app $pkgdir/usr
+}