summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederic Bezies2020-01-06 23:39:43 +0100
committerFrederic Bezies2020-01-06 23:39:43 +0100
commit483c98b1be33ebb820dc1849964b922c33dd114b (patch)
tree55ef071d1dec0226edd77bb43de34ada9ddcbd53 /PKGBUILD
parentfe984f4d6ccb9eb28da4022a2706f2c2a7dba24f (diff)
downloadaur-483c98b1be33ebb820dc1849964b922c33dd114b.tar.gz
1.4.0 update
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD42
1 files changed, 14 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29d1a84a364b..5b2405881a53 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Contributor: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
# Contributor: alex korobtsov <korobcoff@gmail.com>
# Contributor: Alexander Bantyev <balsoft@yandex.ru>
pkgname=qomp
-pkgver=1.3.1
+pkgver=1.4
pkgrel=1
pkgdesc="Quick(Qt) Online Music Player"
arch=('i686' 'x86_64')
@@ -15,17 +16,9 @@ depends=('taglib' 'qt5-base' 'qt5-tools' 'qt5-x11extras'
optdepends=('gst-plugins-bad'
'gst-plugins-ugly')
makedepends=('git' 'cmake')
-_commit=230443ed40a99cedbfee7624dcce6db16977a9f6 #tag 1.3.1
-source=("git+https://github.com/qomp/qomp#commit=$_commit"
- "git+https://github.com/qomp/translations"
- "git+https://github.com/qomp/themes"
- "git+https://github.com/wadealer/SingleApplication"
- 0001-Fixed-compilation-with-Qt-5.11.patch)
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- '83664a00dc0d2ea7cd81a69ff51c40f3')
+_commit=3cbc6ccc5653737b3e1e0b4884bb370e67144604 #tag 1.4.0
+source=(git+https://github.com/qomp/qomp.git#commit=$_commit)
+sha256sums=('SKIP')
pkgver() {
cd $pkgname
@@ -33,30 +26,23 @@ pkgver() {
}
prepare() {
- cd "$srcdir/${pkgname}"
- patch -Np1 -i ../0001-Fixed-compilation-with-Qt-5.11.patch
- git submodule init
-
- git config 'submodule.translations.url' "${srcdir}/translations"
- git config 'submodule.themes.url' "${srcdir}/themes"
- git config 'submodule.src/singleapplication.url' "${srcdir}/SingleApplication"
-
- git submodule update
+ cd "$srcdir/$pkgname"
+ git submodule init
+ git submodule update
}
build() {
- cd "$srcdir/${pkgname}"
+ cd "$srcdir/$pkgname"
- cmake \
- -DCMAKE_INSTALL_PREFIX=/usr/ \
- -DUSE_QT5=ON \
- -DCMAKE_BUILD_TYPE=Release
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
make
}
package() {
- cd "$srcdir/${pkgname}"
+ cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir/" install
}
+
+