summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDonald Carr2016-01-13 17:54:53 -0800
committerDonald Carr2016-01-13 17:54:53 -0800
commit913330c7a3155b6ffae9be222eb9f8cd271bafc5 (patch)
tree18ec60efc0daae97cdfb564402f8f033c83e69e6 /PKGBUILD
parent06b18a1c65e88d1f4025ce29d0d26d334e1d35d6 (diff)
downloadaur-913330c7a3155b6ffae9be222eb9f8cd271bafc5.tar.gz
grabbing controls master repo is courting build failure/disaster
Change-Id: I2d3ad9ed737a4c16a807ae1ce53836302d166568
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 2 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8ddf65236e48..cc097f83d4b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -39,8 +39,8 @@ url="http://www.qt.io"
license=("LGPL3")
depends=("qpi-toolchain" "qtcreator")
makedepends=("git" "pkgconfig" "gcc")
-source=("git://github.com/qtproject/qtquickcontrols2.git" "git://github.com/sirspudd/mkspecs.git" "https://download.qt.io/development_releases/qt/5.6/${_pkgver}/single/${_pipkgname}.tar.gz")
-sha256sums=("SKIP" "SKIP" "d69103ec34b3775edfa47581b14ee9a20789d4b0d7d26220fb92f2cd32eb06f9")
+source=("git://github.com/sirspudd/mkspecs.git" "https://download.qt.io/development_releases/qt/5.6/${_pkgver}/single/${_pipkgname}.tar.gz")
+sha256sums=("SKIP" "d69103ec34b3775edfa47581b14ee9a20789d4b0d7d26220fb92f2cd32eb06f9")
options=('!strip')
install=qpi.install
@@ -108,14 +108,6 @@ build() {
cd "${_bindir}/qtwayland"
${_bindir}/qtbase/bin/qmake CONFIG+=wayland-compositor
make
-
- # temp hack for Qt 5.6.0-beta
- local _controlspath="${_bindir}/qtquickcontrols2/"
- cd "${srcdir}/qtquickcontrols2"
- git checkout-index -a -f --prefix=${_controlspath}
- cd ${_controlspath}
- ${_bindir}/qtbase/bin/qmake
- make
}
package() {
@@ -133,10 +125,6 @@ package() {
cd "${_bindir}/qtwayland"
INSTALL_ROOT="$pkgdir" make install
- # temp hack for Qt 5.6.0-beta
- cd "${_bindir}/qtquickcontrols2"
- INSTALL_ROOT="$pkgdir" make install
-
# Qt is now installed to $pkgdir/$sysroot/$prefix
# manually generate/decompose host/target
local _libsdir="${startdir}/${_libspkgname}"