summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDonald Carr2016-01-14 13:10:12 -0800
committerDonald Carr2016-01-14 14:30:20 -0800
commite5f09de15511170f1855d54107562db1240fccca (patch)
treefb49df97ad7ddd4c7a43f9b8d8a6a81882fb687f /PKGBUILD
parent9c3c4ab7e04e2e0843cba6f4e207a98b74f8bce4 (diff)
downloadaur-e5f09de15511170f1855d54107562db1240fccca.tar.gz
Introduce a variety of useful configure flags
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 13 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a256ade7b1df..1889f2ecfe6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -46,7 +46,7 @@ install=qpi.install
_device_configure_flags=""
if [[ ${_piver} = "1" ]]; then
- _device_configure_flags="-skip qtwebengine"
+ _device_configure_flags="-skip qtwebengine -no-icu"
fi
build() {
@@ -79,14 +79,26 @@ build() {
# patch
local _webenginefileoverride="${_srcdir}/qtwebengine/tools/qmake/mkspecs/features/functions.prf"
sed -i "s/linux-clang/linux*/" ${_webenginefileoverride}
+ local _reducerelocations="${_srcdir}/qtbase/config.tests/unix/bsymbolic_functions.test"
+ sed -i "s/error/warning/" ${_reducerelocations}
+
# end patch
+ # Breaks in qtwayland
+ # -qtnamespace Pi \
+
${_srcdir}/configure \
-qreal float \
-release \
-silent \
-confirm-license \
-opensource \
+ -qtlibinfix Pi \
+ -reduce-exports \
+ -reduce-relocations \
+ -pch \
+ -ltcg \
+ -no-compile-examples \
-hostprefix ${_installprefix} \
-prefix ${_installprefix} \
-opengl es2 \