summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDictator Mei2018-08-14 01:04:28 +0900
committerDictator Mei2018-08-14 01:04:28 +0900
commit74469e07a32dcd7e95156afb8fbc5a85a852dc00 (patch)
tree95fb60e8cbdfb7d9218e6df0d0892b8e2280a510 /PKGBUILD
downloadaur-74469e07a32dcd7e95156afb8fbc5a85a852dc00.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee9bd383aecc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Dictator Mei <dctxmei@gmail.com>
+pkgname=qqbot
+pkgver=2.3.10
+pkgrel=1
+pkgdesc="A conversation robot base on Tencent's SmartQQ"
+arch=('any')
+url="https://github.com/pandolia/qqbot"
+license=('MIT')
+depends=("python" "python-apscheduler" "python-certifi" "python-requests")
+source=("https://github.com/pandolia/qqbot/archive/v$pkgver.tar.gz")
+sha512sums=('c72f8a1c153c97a50adfaeb7704cbdacebcdd01b4a603e1a34ab571447cf3a2747c4da6480f7ce070eccd2b7fe5e3306924a111be1f680947fab245ee266a813')
+
+build() {
+ cd "$srcdir"/qqbot-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd qqbot-$pkgver
+ python setup.py install --root="$pkgdir"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}