summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorButui Hu2021-05-29 13:22:13 +0800
committerButui Hu2021-05-29 13:22:13 +0800
commita4a66652e309b2713d4c5c80bbd838a2f9978216 (patch)
tree96984513db810663146d5919b666c2158d35377c /PKGBUILD
downloadaur-qspec.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7aa66be71493
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Hu Butui <hot123tea123@gmail.com>
+# Contributor: Jens Staal <staal1978@gmail.com>
+
+_pkgname=QSpec
+pkgname=qspec
+pkgver=0.2
+pkgrel=1
+pkgdesc="A GUI testing library for Qt desktop applications"
+arch=('x86_64')
+url='https://github.com/ugeneunipro/QSpec'
+license=('GPL2')
+depends=(
+ libxtst
+ qt5-webkit
+)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ugeneunipro/QSpec/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('6f5d44c6b7b7db82ece5238d343fab44f36dc2d3d56afae51bd122acb352d7bd')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ qmake
+ make
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ make INSTALL_ROOT="${pkgdir}/usr/lib" install
+}
+# vim:set ts=2 sw=2 et:
+