summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGerald Bischof2019-09-29 11:55:06 +0200
committerGerald Bischof2019-09-29 11:55:06 +0200
commit394fbafc723bab7c3bed2713a9ab7589965dff2f (patch)
tree54866c2d06ce8de306c1534477fc51feca227099 /PKGBUILD
downloadaur-qsvgstyle.tar.gz
Version 2019-07-06
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ea652061610
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Gerald Bischof gBischof at gebix dot com
+pkgname=qsvgstyle
+pkgver=20190706
+pkgrel=1
+epoch=
+pkgdesc="Themeable SVG style for KDE Plasma"
+arch=(x86_64)
+url="https://github.com/DexterMagnific/QSvgStyle"
+license=('GPL2')
+groups=()
+depends=(qt5-x11extras qt5-svg)
+makedepends=(qt5-tools)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname::git+https://github.com/DexterMagnific/QSvgStyle.git")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname"
+}
+
+build() {
+ cd "$pkgname"
+ qmake
+ make
+}
+
+check() {
+ cd "$pkgname"
+ make -k check
+}
+
+package() {
+ cd "$pkgname"
+ make INSTALL_ROOT="$pkgdir/" install
+}