summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantinos2017-06-17 19:21:48 +0300
committerKonstantinos2017-06-17 19:21:48 +0300
commit3d58dc3d10810e1af4106a79339ced753052b8b8 (patch)
tree5c0a06c29235a77928d4c88bd9db5d2b48368230 /PKGBUILD
downloadaur-3d58dc3d10810e1af4106a79339ced753052b8b8.tar.gz
useful commit message
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..764b7ad0bde5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Konstantinos Foutzopoulos <mail@konfou.xyz>
+
+_pkgname=qsynth
+pkgname=${_pkgname}-git
+pkgver=r531.999e198
+pkgrel=1
+pkgdesc="A fluidsynth Qt GUI Interface (GIT version)"
+arch=('i686' 'x86_64')
+url="https://qsynth.sourceforge.io/"
+license=('GPL2')
+depends=('fluidsynth' 'qt5-x11extras')
+makedepends=('qt5-tools')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://git.code.sf.net/p/${_pkgname}/code")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ git describe --long | sed -e 's/qsynth_//;s/_/./g;s/-/.r/;s/-/./'
+}
+
+build() {
+ cd ${_pkgname}
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=release
+ make
+}
+
+package() {
+ cd ${_pkgname}
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: