summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntoine Viallon2020-08-24 01:58:42 +0000
committerAntoine Viallon2020-08-24 01:58:42 +0000
commit6fce4a376edb39123f83156b05a5f8b33671b2eb (patch)
tree952e7eaddd129e85078fc2883c24c0d01e07cf11 /PKGBUILD
downloadaur-qt-avif-image-plugin-libavif-git.tar.gz
Use libavif-git instead of avif-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23f4a169b6a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Antoine Viallon <antoine@lesviallon.fr>
+# Contributor: Zan <zan@cock.li>
+
+pkgname=qt-avif-image-plugin-libavif-git
+_basename=${pkgname%-git}
+_pkgname=qt-avif-image-plugin
+pkgver=r68.6920fe4
+pkgrel=1
+pkgdesc='Qt plug-in to allow Qt and KDE based applications to read/write AVIF images.'
+arch=(x86_64)
+url='https://github.com/novomesk/qt-avif-image-plugin'
+license=('BSD')
+depends=(qt5-base libavif-git)
+makedepends=(git extra-cmake-modules)
+source=("git+https://github.com/novomesk/qt-avif-image-plugin.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake "../$_pkgname"
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$_basename/LICENSE"
+}