summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Laß2021-05-09 21:22:07 +0200
committerMichael Laß2021-05-09 21:22:07 +0200
commit017a175aba6f8dfe5a8e48c792f6fb573d5a4dee (patch)
tree639dde24cb80cca5ec2868fcf2b482c2eeae675b /PKGBUILD
parent2a2296573c0f2fab05916da4359e253b4406c2f8 (diff)
downloadaur-017a175aba6f8dfe5a8e48c792f6fb573d5a4dee.tar.gz
Add a couple of patches and fix one optdepend
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 24 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c516d66571f4..a9fd0087073a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,32 +6,49 @@
pkgname=qt-dab
_pkgname=Qt-DAB
pkgver=3.71
-pkgrel=2
+pkgrel=3
pkgdesc="Software DAB decoder for use with various SDR devices"
arch=(x86_64)
url="https://www.sdr-j.tk/"
license=('GPL2')
+#options=(!strip) # for debugging
depends=(faad2 fftw hicolor-icon-theme libsamplerate libsndfile portaudio qwt)
optdepends=('airspy: Support for Airspy'
'hackrf: Support for HackRF'
'limesuite: Support for LimeSDR'
- 'libiio: Support for Pluto'
+ 'libad9361: Support for Pluto'
'rtl-sdr: Support for RTL-SDR'
'libsdrplay: Support for SDRplay')
-source=("https://github.com/JvanKatwijk/${pkgname}/archive/refs/tags/${_pkgname}${pkgver}.tar.gz")
-sha256sums=('8a5ec68a7b920ee3b397fa8d9bd2e773f5e95ca5bb5a939dc907f4509d3df84f')
+source=("https://github.com/JvanKatwijk/${pkgname}/archive/refs/tags/${_pkgname}${pkgver}.tar.gz"
+ "0001-Remove-liio-from-linker-flags-when-using-CMAKE.patch"
+ "0002-Fix-illegal-memory-access-in-fibDecoder-FIG1Extensio.patch"
+ "0003-Leave-K-loop-in-reedSolomon-computeLambda-in-time.patch"
+ "0004-Fix-index-computation-in-SpectrogramData-value.patch")
+sha256sums=('8a5ec68a7b920ee3b397fa8d9bd2e773f5e95ca5bb5a939dc907f4509d3df84f'
+ 'eecc7813f00586dc37212971a5106a0ba4c106a3970a79e90fe8de1afd13a35a'
+ '914eff3d5230d161af38ef1f85e3cecd45f2b150efc9ff8460e4be22f175319c'
+ '1e22af5dc6ac8ec4ed512675d3606a8fa68245ba37ecf6a09045cbcf21a1a3c4'
+ 'e2f998ec4495acc1141a9c8afa8a3fcc48de53a9214430443f474b6955c54490')
prepare() {
+ cd "${pkgname}-${_pkgname}${pkgver}"
+
# The program is officially called Qt-DAB.
- sed -i 's/Qt_DAB/Qt-DAB/g' ${pkgname}-${_pkgname}${pkgver}/dab-maxi/${pkgname}.desktop
+ sed -i 's/Qt_DAB/Qt-DAB/g' dab-maxi/${pkgname}.desktop
- # -liio is not required. Remove to make libiio optional.
- sed -i '/list(APPEND extraLibs -liio)/d' ${pkgname}-${_pkgname}${pkgver}/dab-maxi/CMakeLists.txt
+ # Various stability and build system fixes
+ patch -p1 < "${srcdir}/0001-Remove-liio-from-linker-flags-when-using-CMAKE.patch"
+ patch -p1 < "${srcdir}/0002-Fix-illegal-memory-access-in-fibDecoder-FIG1Extensio.patch"
+ patch -p1 < "${srcdir}/0003-Leave-K-loop-in-reedSolomon-computeLambda-in-time.patch"
+ patch -p1 < "${srcdir}/0004-Fix-index-computation-in-SpectrogramData-value.patch"
}
build() {
mkdir -p build-maxi; cd build-maxi
+ # for debugging
+ # CXXFLAGS="$CXXFLAGS -fsanitize=address -g" \
+ # LDFLAGS="$LDFLAGS -fsanitize=address -g" \
cmake \
-Wno-dev \
-DTRY_EPG=ON \