summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZhang Hua2024-02-06 19:09:04 +0800
committerZhang Hua2024-02-06 19:09:04 +0800
commit4933588b720c0a1a0ae268cd43cd33125ce591e0 (patch)
tree90c3885571fa472f35d59cbc9ae74ff3ca4dc8c8 /PKGBUILD
parent7edb432b661c28ecf51d79ca2a848e99248cc1e9 (diff)
downloadaur-4933588b720c0a1a0ae268cd43cd33125ce591e0.tar.gz
Use diff provided by upstream instead myself
Also using SPDX licence identifier and follow CMake package guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 574ff8ac3913..37b5e8103cd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,37 @@
pkgbase=qt-heic-image-plugin
pkgname=(qt5-heic-image-plugin qt6-heic-image-plugin)
pkgver=0.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Qt plug-in to allow Qt and KDE based applications to read/write HEIF/HEIC images."
arch=("x86_64")
url="https://github.com/novomesk/qt-heic-image-plugin"
-license=("GPL")
+license=("LGPL-2.1-only")
depends=(libheif)
makedepends=(cmake extra-cmake-modules qt5-base qt6-base)
source=(
"$url/archive/refs/tags/v$pkgver.tar.gz"
# Add QT_MAJOR_VERSION to switch between qt versions easily
- "https://github.com/novomesk/qt-heic-image-plugin/pull/4.diff")
+ "0001-Add-QT_MAJOR_VERSION.diff::https://github.com/arenekosreal/qt-heic-image-plugin/commit/dada91b071b6f2900638fd0f3ea8eb82b6de479b.diff")
sha256sums=('f3e611cecb4918cb17d089e1912451b2ec42cb1f9efc496428b219f78a334cb6'
- '195cb86198fad00a0e7e1500b666ca3591f31740b06447fc4972a2bbf74b7f4a')
+ '1ddadd5676f43fdd11d3a452eae253699b64baf213d13942f44cb6c87b3dccfd')
prepare() {
cd qt-heic-image-plugin-$pkgver
- patch -p1 -i "$srcdir/4.diff"
+ patch -p1 -i "$srcdir/0001-Add-QT_MAJOR_VERSION.diff"
}
build() {
msg2 "Building QT5 version..."
cmake -B build-qt5 -S qt-heic-image-plugin-$pkgver \
-DCMAKE_INSTALL_PREFIX="/usr" \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=None \
-DQT_MAJOR_VERSION=5
cmake --build build-qt5
msg2 "Building QT6 version..."
cmake -B build-qt6 -S qt-heic-image-plugin-$pkgver \
-DCMAKE_INSTALL_PREFIX="/usr" \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=None \
-DQT_MAJOR_VERSION=6
cmake --build build-qt6
}