aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDonald Carr2021-09-08 20:54:06 -0700
committerDonald Carr2021-09-08 20:54:06 -0700
commitc9596ff952838b30c203e0b7fed38817201bbc79 (patch)
treeb7ebf8917708e675c318e440f07b98cfb3b7e30e /PKGBUILD
parentc74d51e69fd9eaed257dd85b5e2b9d447ea43038 (diff)
downloadaur-c9596ff952838b30c203e0b7fed38817201bbc79.tar.gz
Start to include the docs in sdk builds
Change-Id: I1da52c37882f49dd91ab7dcb9ce8a0a908a74a00
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 455c7d4fd81a..5e727d74f94e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -123,7 +123,7 @@ _pkgvermajmin="6.2"
_pkgverpatch=".0"
# {alpha/beta/beta2/rc}
_dev_suffix="beta3"
-pkgrel=4
+pkgrel=5
pkgver="${_pkgvermajmin}${_pkgverpatch}"
$_build_from_local_src_tree && pkgver=6.6.6
_pkgver=${pkgver}
@@ -362,6 +362,7 @@ fi
set &> configure_env
${_configure_line}
cmake --build . --parallel
+ cmake --build . --target docs
}
create_install_script() {
@@ -415,7 +416,8 @@ package() {
mkdir -p ${_libspkgdir} ${_libsdebugpkgdir} ${pkgdir}
cd "${_bindir}"
- DESTDIR="$pkgdir" ninja install || exit 1
+ DESTDIR="$pkgdir" cmake --build . --target install
+ DESTDIR="$pkgdir" cmake --build . --target install_docs
# attempt to fix Qt 5.12.1's insane complete qualification of linked libraries
# this still results in other sources of the complete path