aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDonald Carr2017-09-19 00:44:12 -0700
committerDonald Carr2017-09-19 00:44:12 -0700
commit438bb73b058ddec2cfb9a59620398b0cee1b7e4c (patch)
treee4e6c80f51f1e0560dba6ebcad8a636b951922a1 /PKGBUILD
parent520e7dbf27d2ada11c0a20245c1e9a61c5e5c074 (diff)
downloadaur-438bb73b058ddec2cfb9a59620398b0cee1b7e4c.tar.gz
There is no need to remove sysroot offset on static builds when targeting the host
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index beaa6a1450df..2e311277f77f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -449,7 +449,9 @@ package() {
find $(basename ${_installed_dir}) -name '*.debug' -exec cp --parents '{}' ${_libsdebugpkgdir} \; -exec rm '{}' \;
if $_static_build; then
- mv ${_installed_dir} ${_installed_dir_sans_sysroot_offset}
+ if ! $_target_host; then
+ mv ${_installed_dir} ${_installed_dir_sans_sysroot_offset}
+ fi
else
mv ${_installed_dir} ${_libspkgdir}
fi