summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDonald Carr2016-02-02 17:33:49 -0800
committerDonald Carr2016-02-02 17:33:49 -0800
commit0bf662edbdecc45574b11b6d73fb8fab0b274d55 (patch)
tree2aed8802b9d138942e98c56a589fdfbce094f685 /PKGBUILD
parent31b3c851461e4412c3f857274bc588a74d9eab46 (diff)
downloadaur-0bf662edbdecc45574b11b6d73fb8fab0b274d55.tar.gz
Spruce up documentation
Change-Id: I2a41dedb1fc2929cfac67dd3a40f29795dbfaee6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 12 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6c9a75531f17..ac6178d904c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,27 @@
# Documentation
-# Set up the pi for Qt compilation. On Arch I just install chromium which pulls in all the deps
-# Removed xcomposite as code path breaks
+# Set up the pi for Qt compilation.
+# For a comprehensive set of deps I just install chromium which pulls in everything
-# Remove 2 (mesa) pkgconfig files we allow screw our mkspec
-# rm /usr/lib/pkgconfig/glesv2.pc
-# rm /usr/lib/pkgconfig/egl.pc
+#* I had to removed xcomposite as code path breaks
+#* Remove 2 (mesa) pkgconfig files we allow to screw our mkspec
+# * rm /usr/lib/pkgconfig/glesv2.pc
+# * rm /usr/lib/pkgconfig/egl.pc
-# You are gonna want to export the following vars in /etc/profile.d
-# if you intend to primarily use Wayland
+# NB! Mount/copy this prepped rasp rootfs somewhere and set this path as the sysroot below
+# I use NFS personally: sudo mount qpi2.local:/ /mnt/pi
+# comment this turkey out in any circumstance when you need to regenate .SRCINFO
-#export QT_QPA_PLATFORM=wayland
-#export QT_WAYLAND_CLIENT_BUFFER_INTEGRATION=brcm
+# Mandatory edit
-# Mount/copy this prepped rasp rootfs somewhere and set this path as the sysroot below
-# I use NFS personally: sudo mount qpii.local:/ /mnt/pi
+echo "Set your sysroot below prior to build then delete this line" && exit 1
+_sysroot=/mnt/pi
# Options
_skip_web_engine=true
-# comment this turkey out in any circumstance when you need to regenate .SRCINFO
-echo "Set your sysroot prior to build" && exit 1
-_sysroot=/mnt/pi
-
_piver=2
_pkgname=qt-sdk-raspberry-pi
provides=("${_pkgname}")