summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDonald Carr2016-03-15 15:48:24 -0700
committerDonald Carr2016-03-15 15:52:18 -0700
commited0498e627217934ba272a8eef1d1f874a359892 (patch)
tree32f28a7ed1ad1819be39bd1217d5bbe8ce07e9c9 /PKGBUILD
parent376b81dc0c11ddd0e8f403e5ea253dd98dbd842a (diff)
downloadaur-ed0498e627217934ba272a8eef1d1f874a359892.tar.gz
No longer require wayland work around
Change-Id: I243bb82e7ab9f5cb4e343988fc5f8146850e7604
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 0 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 680c1e088057..53aa0cecdd5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,6 @@ _skip_web_engine=false
_static_build=false
_build_from_head=false
_local_qt5_repo="/opt/dev/src/qtproject/qt5"
-_wayland_compositor_workaround=false
_pkgvermajmin="5.7"
pkgver="${_pkgvermajmin}.0"
@@ -102,10 +101,6 @@ if $_build_from_head; then
_device_configure_flags="$_device_configure_flags -skip qt3d -skip qtsystems -skip qttools -skip qtwebkit"
fi
-if $_wayland_compositor_workaround; then
- _device_configure_flags="$_device_configure_flags -skip qtwayland"
-fi
-
# bug(s) in Qt 5.7.0-alpha
_device_configure_flags="$_device_configure_flags -skip qtlocation"
@@ -197,16 +192,6 @@ fi
${_device_configure_flags} || exit 1
make || exit 1
-
-if $_wayland_compositor_workaround; then
- # regrettably required, as qtwayland barfs on shadow builds
- # as private header paths not included: no clue how to fix, bypassing
-
- cp -r "${_srcdir}/qtwayland" "${_bindir}" || exit 1
- cd "${_bindir}/qtwayland"
- ${_bindir}/qtbase/bin/qmake CONFIG+=wayland-compositor || exit 1
- make || exit 1
-fi
}
create_install_script()
@@ -231,12 +216,6 @@ package() {
cd "${_bindir}"
INSTALL_ROOT="$pkgdir" make install || exit 1
-if $_wayland_compositor_workaround; then
- # regrettably required
- cd "${_bindir}/qtwayland"
- INSTALL_ROOT="$pkgdir" make install || exit 1
-fi
-
# Qt is now installed to $pkgdir/$sysroot/$prefix
# manually generate/decompose host/target
local _libsdir="${startdir}/${_libspkgname}"