summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames Bunton2019-02-09 09:39:14 +1100
committerJames Bunton2019-02-09 09:39:14 +1100
commit5abe6327e6f72ff88fcdf569ac5a3a0818c7335b (patch)
treee89127479bc0f85bea05d84963589c7a60f910eb /PKGBUILD
parentee1c81dea2db536c0ebf12e6e6b25e4d044a2145 (diff)
downloadaur-5abe6327e6f72ff88fcdf569ac5a3a0818c7335b.tar.gz
v5.12.1-2: sync from upstream package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0564c5a89921..94c9b0b7a125 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ _pkgbase=qt5-base
pkgname=(qt5-base-nostatx qt5-xcb-private-headers-nostatx)
_qtver=5.12.1
pkgver=${_qtver/-/}
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url='https://www.qt.io'
license=('GPL3' 'LGPL3' 'FDL' 'custom')
@@ -39,10 +39,12 @@ groups=('qt' 'qt5')
_pkgfqn="${_pkgbase/5-/}-everywhere-src-${_qtver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
qt-delayed-highlight.patch::https://code.qt.io/cgit/qt/qtbase.git/patch/?id=f8f0f3ee
- qtbug-69310.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=fcba9fa8")
+ qtbug-69310.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=fcba9fa8"
+ qt5-base-nouveau-freeze.patch::"http://code.qt.io/cgit/qt/qtbase.git/patch?id=97600d2c")
sha256sums=('533078ce02678988576e224cb3844979907950cf83e0fda3364bc1d5701c9049'
'0080b1e208090c729018db1ac224e5940d06a38b9c28c918a892b01f84a82cf9'
- '2186ce7b8d6310ebc005da9b00dcc88388df3e8b83bff37230fa1bb9253c4970')
+ '2186ce7b8d6310ebc005da9b00dcc88388df3e8b83bff37230fa1bb9253c4970'
+ 'e0a7cdda2ebc403e2b3a62b3d104d2dd3f8b4e79d92395cf3c6419ebe6d8b19c')
prepare() {
cd ${_pkgfqn}
@@ -56,6 +58,7 @@ prepare() {
patch -p1 -i ../qt-delayed-highlight.patch # https://codereview.qt-project.org/#/c/249881/
patch -p1 -i ../qtbug-69310.patch # https://bugreports.qt.io/browse/QTBUG-69310
+ patch -Rp1 -i ../qt5-base-nouveau-freeze.patch # Revert commit that causes freezes on nouveau https://bugreports.qt.io/browse/QTBUG-73691
}
build() {