summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames Bunton2019-03-20 09:35:47 +1100
committerJames Bunton2019-03-20 09:36:09 +1100
commit66a8ec1a84522d672b8b12cbdb84d90cf8db4507 (patch)
treebe8bce161e2f3307cbc9da1672d802e8f45cc8c7 /PKGBUILD
parent5abe6327e6f72ff88fcdf569ac5a3a0818c7335b (diff)
downloadaur-66a8ec1a84522d672b8b12cbdb84d90cf8db4507.tar.gz
v5.12.2-1: sync from upstream package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 4 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 94c9b0b7a125..85968612b902 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,9 +14,9 @@
pkgbase=qt5-base-nostatx
_pkgbase=qt5-base
pkgname=(qt5-base-nostatx qt5-xcb-private-headers-nostatx)
-_qtver=5.12.1
+_qtver=5.12.2
pkgver=${_qtver/-/}
-pkgrel=2
+pkgrel=1
arch=('x86_64')
url='https://www.qt.io'
license=('GPL3' 'LGPL3' 'FDL' 'custom')
@@ -37,14 +37,8 @@ optdepends=('qt5-svg: to use SVG icon themes'
conflicts=('qtchooser')
groups=('qt' 'qt5')
_pkgfqn="${_pkgbase/5-/}-everywhere-src-${_qtver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
- qt-delayed-highlight.patch::https://code.qt.io/cgit/qt/qtbase.git/patch/?id=f8f0f3ee
- qtbug-69310.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=fcba9fa8"
- qt5-base-nouveau-freeze.patch::"http://code.qt.io/cgit/qt/qtbase.git/patch?id=97600d2c")
-sha256sums=('533078ce02678988576e224cb3844979907950cf83e0fda3364bc1d5701c9049'
- '0080b1e208090c729018db1ac224e5940d06a38b9c28c918a892b01f84a82cf9'
- '2186ce7b8d6310ebc005da9b00dcc88388df3e8b83bff37230fa1bb9253c4970'
- 'e0a7cdda2ebc403e2b3a62b3d104d2dd3f8b4e79d92395cf3c6419ebe6d8b19c')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('562c095a59c95f393762ec53bc05c0d80fad1758fd5ff7a5231967d1a98d56c1')
prepare() {
cd ${_pkgfqn}
@@ -55,10 +49,6 @@ prepare() {
mkspecs/common/gcc-base.conf
sed -i -e "s|^\(QMAKE_LFLAGS_RELEASE.*\)|\1 ${LDFLAGS}|" \
mkspecs/common/g++-unix.conf
-
- patch -p1 -i ../qt-delayed-highlight.patch # https://codereview.qt-project.org/#/c/249881/
- patch -p1 -i ../qtbug-69310.patch # https://bugreports.qt.io/browse/QTBUG-69310
- patch -Rp1 -i ../qt5-base-nouveau-freeze.patch # Revert commit that causes freezes on nouveau https://bugreports.qt.io/browse/QTBUG-73691
}
build() {