summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSkycoder422017-04-15 15:15:03 +0200
committerSkycoder422017-04-15 15:15:03 +0200
commit3671a777bba2c8169a433407dc5ffb138d9feb8c (patch)
tree540f9c2f009348377cfeb35ad1b23293f5c49dd2 /PKGBUILD
parentc562bc273b9bc64a5026eddddefd80d6bcc381ab (diff)
downloadaur-3671a777bba2c8169a433407dc5ffb138d9feb8c.tar.gz
fixed missing build deps for qpm
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6d49f1b9a49..cb85d8765e72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,22 @@
# Maintainer: Felix Barz <skycoder42.de@gmx.de>
pkgname=qt5-datasync
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A simple offline-first synchronisation framework, to synchronize data of Qt applications between devices"
arch=('i686' 'x86_64')
url="https://github.com/Skycoder42/QtDataSync"
license=('BSD')
depends=('qt5-base' 'qt5-tools' 'qt5-jsonserializer>=2.0.0' 'qt5-backgroundprocess>=1.5.0' 'qt5-websockets')
-makedepends=('git')
+makedepends=('git' 'qpm')
source=("$pkgname-$pkgver::git+https://github.com/Skycoder42/QtDataSync.git#tag=$pkgver")
md5sums=('SKIP')
build() {
cd "$pkgname-$pkgver"
+
+ cd src/3rdparty
+ qpm install
+ cd ../..
qmake
make qmake_all