summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSkycoder422017-03-26 14:45:12 +0200
committerSkycoder422017-03-26 14:45:12 +0200
commit9a2a6305b210e8b609fc3a391fcf3a4cbbbd865d (patch)
tree6bdb4bd403bf9f89dcfd94048d692e167e179e12 /PKGBUILD
downloadaur-9a2a6305b210e8b609fc3a391fcf3a4cbbbd865d.tar.gz
created package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..818430a2b06d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Felix Barz <skycoder42.de@gmx.de>
+pkgname=qt5-datasync
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A simple offline-first synchronisation framework, to synchronize data of Qt applications between devices"
+arch=('i686' 'x86_64')
+url="https://github.com/Skycoder42/QtDataSync"
+license=('BSD')
+depends=('qt5-base' 'qt5-tools' 'qt5-jsonserializer' 'qt5-backgroundprocess')
+makedepends=('git')
+source=("$pkgname-$pkgver::git+https://github.com/Skycoder42/QtDataSync.git#tag=$pkgver")
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ qmake
+ make qmake_all
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ FILE=$pkgdir/usr/lib/libQt5DataSync.prl
+ tail -n +2 "$FILE" > "$FILE.tmp"
+ mv "$FILE.tmp" "$FILE"
+
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}