summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12023-04-12 22:42:45 +0800
committerChocobo12023-04-12 22:42:45 +0800
commitb9c0e44256446a0f97149bb131d907a0f86389c4 (patch)
tree257716b35b1bc6f42be76467a6117f87aa566244 /PKGBUILD
parentcac7bab713d62ce248e0736a9e62fb16bd9343a0 (diff)
downloadaur-qt5-quickcontrols-git.tar.gz
upgpkg: qt5-quickcontrols-git 5.15.9.r0.geb9dead1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67aaab0bdd05..6f0dfd2a682f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
pkgname=qt5-quickcontrols-git
-pkgver=5.15.1.r1.ge82f3998
+pkgver=5.15.9.r0.geb9dead1
pkgrel=1
pkgdesc="Qt5 Quick Controls module"
arch=('i686' 'x86_64')
@@ -13,7 +13,7 @@ url="https://www.qt.io/"
license=('FDL' 'GPL' 'LGPL' 'custom')
depends=('qt5-declarative')
makedepends=('git')
-provides=('qt5-quickcontrols')
+provides=("qt5-quickcontrols=$pkgver")
conflicts=('qt5-quickcontrols')
source=("git+https://code.qt.io/qt/qtquickcontrols.git#branch=5.15")
sha256sums=('SKIP')
@@ -28,10 +28,10 @@ prepare() {
pkgver() {
cd "qtquickcontrols"
- _tag=$(git tag -l --sort -v:refname | head -n1)
+ _tag=$(git tag -l --sort -creatordate | grep -E '^v5\.15[0-9\.]+' | head -n1)
_rev=$(git rev-list --count $_tag..HEAD)
_hash=$(git rev-parse --short HEAD)
- printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//;s/-/_/g'
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//;s/-lts-lgpl//'
}
build() {